PrimeGrid
Please visit donation page to help the project cover running costs for this month
1) Message boards : Proth Prime Search : gpu task problem (Message 28502)
Posted 3583 days ago by Profile tocxProject donor
- make 10 test per driver (5 per card, 2x MSI N460GTX CYCLONE OC 1GD5)
- all tasks with driver 260.xx have errors, but the the number of factors before the task aborted is differing
- delete stderr.txt, tpfactors.txt and tpcheck*.txt (if available) between runs

driver 256.53 (GTX460):
#######################

./tpsieve-cuda-boinc-x86_64-linux -p420700e9 -P420701000e6 -k 1201 -K 9999 -N 3000000 -c 60 -M 2 -T -m 64 --device 0
tpsieve version cuda-0.2.2e (testing)
Compiled Nov 27 2010 with GCC 4.3.3
nstart=82, nstep=36
nstep changed to 32
tpsieve initialized: 1201 <= k <= 9999, 82 <= n < 3000000
...
Found 208 factors

more stderr.txt
shmget in attach_shmem: Invalid argument
Can't set up shared mem: -1
Will run in standalone mode.
Sieve started: 420700000000000 <= p < 420701000000000
Thread 0 starting
Detected GPU 0: GeForce GTX 460
Detected compute capability: 2.1
Detected 7 multiprocessors.

Thread 0 completed
Sieve complete: 420700000000000 <= p < 420701000000000
count=29703006,sum=0x69ccf6011cb93a06
Elapsed time: 248.63 sec. (0.04 init + 248.59 sieve) at 4022983 p/sec.
Processor time: 4.57 sec. (0.04 init + 4.52 sieve) at 221047039 p/sec.
Average processor utilization: 1.06 (init), 0.02 (sieve)
called boinc_finish


driver 260.19.12 (GTX460):
##########################

./tpsieve-cuda-boinc-x86_64-linux -p420700e9 -P420701000e6 -k 1201 -K 9999 -N 3000000 -c 60 -M 2 -T -m 64 --device 0
tpsieve version cuda-0.2.2e (testing)
Compiled Nov 27 2010 with GCC 4.3.3
nstart=82, nstep=36
nstep changed to 32
tpsieve initialized: 1201 <= k <= 9999, 82 <= n < 3000000

more stderr.txt
shmget in attach_shmem: Invalid argument
Can't set up shared mem: -1
Will run in standalone mode.
Sieve started: 420700000000000 <= p < 420701000000000
Thread 0 starting
Detected GPU 0: GeForce GTX 460
Detected compute capability: 2.1
Detected 7 multiprocessors.
Computation Error: no candidates found for p=420700026453163.
called boinc_finish


driver 260.19.21 (GTX460):
##########################

./tpsieve-cuda-boinc-x86_64-linux -p420700e9 -P420701000e6 -k 1201 -K 9999 -N 3000000 -c 60 -M 2 -T -m 64 --device 0
tpsieve version cuda-0.2.2e (testing)
Compiled Nov 27 2010 with GCC 4.3.3
nstart=82, nstep=36
nstep changed to 32
tpsieve initialized: 1201 <= k <= 9999, 82 <= n < 3000000

more stderr.txt
shmget in attach_shmem: Invalid argument
Can't set up shared mem: -1
Will run in standalone mode.
Sieve started: 420700000000000 <= p < 420701000000000
Thread 0 starting
Detected GPU 0: GeForce GTX 460
Detected compute capability: 2.1
Detected 7 multiprocessors.
Computation Error: no candidates found for p=420700154581337.
called boinc_finish
2) Message boards : Proth Prime Search : gpu task problem (Message 28500)
Posted 3583 days ago by Profile tocxProject donor
test with driver 256.53 & 260.19.xx on GTX460

driver 256.53 (GTX460):
###################

./tpsieve-cuda-x86_64-linux -p420700e9 -P420701000e6 -k 1201 -K 9999 -N 3000000 -c 60 -M 2 -T -m 64 --device 0
tpsieve version cuda-0.2.2e (testing)
Compiled Nov 27 2010 with GCC 4.3.3
nstart=82, nstep=36
nstep changed to 32
tpsieve initialized: 1201 <= k <= 9999, 82 <= n < 3000000
Sieve started: 420700000000000 <= p < 420701000000000
Thread 0 starting
Detected GPU 0: GeForce GTX 460
Detected compute capability: 2.1
Detected 7 multiprocessors.
....
Thread 0 completed
Waiting for threads to exit
Sieve complete: 420700000000000 <= p < 420701000000000
Found 208 factors
count=29703006,sum=0x69ccf6011cb93a06
Elapsed time: 250.62 sec. (0.04 init + 250.58 sieve) at 3991101 p/sec.
Processor time: 4.68 sec. (0.04 init + 4.64 sieve) at 215520875 p/sec.
Average processor utilization: 0.98 (init), 0.02 (sieve)


driver 260.19.12 (GTX460):
#####################

./tpsieve-cuda-x86_64-linux -p420700e9 -P420701000e6 -k 1201 -K 9999 -N 3000000 -c 60 -M 2 -T -m 64 --device 0
tpsieve version cuda-0.2.2e (testing)
Compiled Nov 27 2010 with GCC 4.3.3
nstart=82, nstep=36
nstep changed to 32
tpsieve initialized: 1201 <= k <= 9999, 82 <= n < 3000000
Sieve started: 420700000000000 <= p < 420701000000000
Resuming from checkpoint p=420700689438721 in tpcheck420700e9.txt
Thread 0 starting
Detected GPU 0: GeForce GTX 460
Detected compute capability: 2.1
Detected 7 multiprocessors.
....
Thread 0 completed
Waiting for threads to exit
Sieve complete: 420700000000000 <= p < 420701000000000
Found 208 factors
count=29703006,sum=0x69ccf6011cb93a06
Elapsed time: 259.13 sec. (0.04 init + 259.09 sieve) at 3859950 p/sec.
Processor time: 4.66 sec. (0.04 init + 4.61 sieve) at 216829339 p/sec.
Average processor utilization: 1.02 (init), 0.02 (sieve)


driver 260.19.21 (GTX460):
#####################

./tpsieve-cuda-x86_64-linux -p420700e9 -P420701000e6 -k 1201 -K 9999 -N 3000000 -c 60 -M 2 -T -m 64 --device 0
tpsieve version cuda-0.2.2e (testing)
Compiled Nov 27 2010 with GCC 4.3.3
nstart=82, nstep=36
nstep changed to 32
tpsieve initialized: 1201 <= k <= 9999, 82 <= n < 3000000
Sieve started: 420700000000000 <= p < 420701000000000
Resuming from checkpoint p=420700090963969 in tpcheck420700e9.txt
Thread 0 starting
Detected GPU 0: GeForce GTX 460
Detected compute capability: 2.1
Detected 7 multiprocessors.
....
Thread 0 completed
Waiting for threads to exit
Sieve complete: 420700000000000 <= p < 420701000000000
Found 208 factors
count=29703006,sum=0x69ccf6011cb93a06
Elapsed time: 235.51 sec. (0.07 init + 235.43 sieve) at 3861472 p/sec.
Processor time: 4.42 sec. (0.04 init + 4.38 sieve) at 207737311 p/sec.
Average processor utilization: 0.59 (init), 0.02 (sieve)
3) Message boards : Proth Prime Search : gpu task problem (Message 28484)
Posted 3584 days ago by Profile tocxProject donor
After work (22:00 UTC) i can make same tests with the 260 driver. I can also make same tests with 260GTX if needed.

2xGTX460 driver 256.53:

<cmdline> -m 8</cmdline> works (same runtime, same cpu-time; but i had only time for some fast tests)

./tpsieve-cuda-x86_64-linux -p420700e9 -P420701000e6 -k 1201 -K 9999 -N 3000000 -c 60 -M 2 -T -m 64 --device 0
......
Thread 0 completed
Waiting for threads to exit
Sieve complete: 420700000000000 <= p < 420701000000000
Found 208 factors
count=29703006,sum=0x69ccf6011cb93a06
Elapsed time: 250.82 sec. (0.04 init + 250.78 sieve) at 3987928 p/sec.
Processor time: 4.78 sec. (0.04 init + 4.74 sieve) at 210974032 p/sec.
Average processor utilization: 1.04 (init), 0.02 (sieve)
4) Message boards : Proth Prime Search : gpu task problem (Message 28418)
Posted 3585 days ago by Profile tocxProject donor

256.53: works good with new workunits, not tested with old

I became some resends of old workunits and i have no errors with 256.53. Looks like that the driver is faster than 256.44.
5) Message boards : Proth Prime Search : gpu task problem (Message 28390)
Posted 3585 days ago by Profile tocxProject donor
With the old Workunits (1800 credits) i had also no problems with driverversion 260.19.21, but after PG send out new work (2314 credits) all wus ended with error.

tested driver on 460GTX:
260.19.21: works fine with old workunits, error with new workunits
260.19.12: erros with new workunits, not tested with old
256.53: works good with new workunits, not tested with old
256.44: works fine with old and new, but is 40 seconds slower on old wus in comparison with 260.19.21
6) Message boards : Proth Prime Search : gpu task problem (Message 28382)
Posted 3586 days ago by Profile tocxProject donor
I think this is a driver problem. I have no problems with my 260GTX with driver 256.44. After downgrading the driver on my other computer (2x460GTX) from 260.19.xx to 256.53 i have no errors. I test both driverversions of the 260.19, i get errors with both.
Both systems run with Debian GNU Linux testing.
7) Message boards : Sieving : ppsieve ATI/OpenCL testing (Message 26010)
Posted 3674 days ago by Profile tocxProject donor
./ppsieve-cl-boinc-x86_64-linux -p42070e9 -P42070010e6 -k 1201 -K 9999 -N 2000000 -c 60 --device 1
ppsieve version cl-0.0.1-alpha (testing)
Compiled Aug 28 2010 with GCC 4.3.3
nstart=76, nstep=32, gpu_nstep=32
ppsieve initialized: 1201 <= k <= 9999, 76 <= n <= 2000000

# more stderr.txt
shmget in attach_shmem: Invalid argument
Can't set up shared mem: -1
Will run in standalone mode.
Sieve started: 42070000000000 <= p < 42070010000000
Thread 0 starting
Invalid MIT-MAGIC-COOKIE-1 keySIGSEGV: segmentation violation
Stack trace (10 frames):
./ppsieve-cl-boinc-x86_64-linux[0x414d8d]
/lib/libpthread.so.0(+0xef60)[0x7f0558473f60]
/home/tocx/download/ati-stream-sdk-v2.2-lnx64/lib/x86_64/libatiocl64.so(+0xca3b0)[0x7f055654f3b0]
/home/tocx/download/ati-stream-sdk-v2.2-lnx64/lib/x86_64/libatiocl64.so(+0x10b640)[0x7f0556590640]
/home/tocx/download/ati-stream-sdk-v2.2-lnx64/lib/x86_64/libatiocl64.so(clCreateCommandQueue+0x69)[0x7f0556533879]
./ppsieve-cl-boinc-x86_64-linux[0x410e15]
./ppsieve-cl-boinc-x86_64-linux[0x40e83e]
./ppsieve-cl-boinc-x86_64-linux[0x40ad5e]
/lib/libc.so.6(__libc_start_main+0xfd)[0x7f0557976c4d]
./ppsieve-cl-boinc-x86_64-linux[0x409fd9]

Exiting...

suspending the wus on gpu gives the same result
---
trying with other devices

shmget in attach_shmem: Invalid argument
Can't set up shared mem: -1
Will run in standalone mode.
Sieve started: 42070000000000 <= p < 42070010000000
Thread 0 starting
Invalid MIT-MAGIC-COOKIE-1 keyCreating Command Queue. (clCreateCommandQueue)
called boinc_finish
8) Message boards : Sieving : ppsieve ATI/OpenCL testing (Message 26006)
Posted 3674 days ago by Profile tocxProject donor

Don't forget to get this ICD registration file and extract it in the root directory, as root.

Thanks for the hint. I extract this but not to /.

./ppsieve-cl-boinc-x86_64-linux -p42070e9 -P42070010e6 -k 1201 -K 9999 -N 2000000 -c 60
ppsieve version cl-0.0.1-alpha (testing)
Compiled Aug 28 2010 with GCC 4.3.3
nstart=76, nstep=32, gpu_nstep=32
ppsieve initialized: 1201 <= k <= 9999, 76 <= n <= 2000000
42070003511309 | 6057*2^1043547+1
42070006307657 | 1513*2^1771812+1
42070006388603 | 2059*2^1816098+1
42070007177519 | 5437*2^1121592+1
42070007396759 | 7339*2^1803518+1
42070008823897 | 4639*2^952018+1
42070008858187 | 2893*2^317690+1
Found 10 factors

# more stderr.txt
shmget in attach_shmem: Invalid argument
Can't set up shared mem: -1
Will run in standalone mode.
Sieve started: 42070000000000 <= p < 42070010000000
Resuming from checkpoint p=42070003407873 in ppcheck42070e9.txt
Thread 0 starting
Invalid MIT-MAGIC-COOKIE-1 keyDetected 4 multiprocessors (20 SPUs) on device 0.

Thread 0 completed
Sieve complete: 42070000000000 <= p < 42070010000000
count=318533,sum=0xb9f8cbeb13d00db3
Elapsed time: 46.20 sec. (0.01 init + 46.18 sieve) at 147577 p/sec.
Processor time: 158.15 sec. (0.02 init + 158.13 sieve) at 43102 p/sec.
Average processor utilization: 1.10 (init), 3.42 (sieve)
called boinc_finish
9) Message boards : Sieving : ppsieve ATI/OpenCL testing (Message 26004)
Posted 3674 days ago by Profile tocxProject donor
O.K., I tested it again, with the libOpenCl.so from SDK V2.2. I get the same message:
./ppsieve-cl-boinc-x86_64-linux: error while loading shared libraries: libOpenCL.so: cannot open shared object file: No such file or directory

Is it expecting the file to be in a location other than where it launches from?


Linux search in the libarypath.
Have you set the 2 Variables from the instruction?
If not copy or link the lib to /usr/lib/ or set the 2 variables.
After that you can test with ldd:

ldd ppsieve-cl-boinc-x86_64-linux
linux-vdso.so.1 => (0x00007fff4e9ff000)
libOpenCL.so => /home/tocx/download/ati-stream-sdk-v2.2-lnx64/lib/x86_64/libOpenCL.so (0x00007f32533f9000)
libpthread.so.0 => /lib/libpthread.so.0 (0x00007f32531d1000)
libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x00007f3252ebc000)
libm.so.6 => /lib/libm.so.6 (0x00007f3252c3a000)
libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x00007f3252a24000)
libc.so.6 => /lib/libc.so.6 (0x00007f32526c2000)
/lib64/ld-linux-x86-64.so.2 (0x00007f3253600000)
libdl.so.2 => /lib/libdl.so.2 (0x00007f32524be000)
librt.so.1 => /lib/librt.so.1 (0x00007f32522b6000)
10) Message boards : Sieving : ppsieve ATI/OpenCL testing (Message 26002)
Posted 3674 days ago by Profile tocxProject donor
OS: Debian GNU Linux Squeeze
GPU: ATI HD 5750 1024MB
Driver: 10.7
SDK: ati-stream-sdk-v2.2-lnx64

./ppsieve-cl-boinc-x86_64-linux -p42070e9 -P42070010e6 -k 1201 -K 9999 -N 2000000 -c 60
ppsieve version cl-0.0.1-alpha (testing)
Compiled Aug 28 2010 with GCC 4.3.3
nstart=76, nstep=32, gpu_nstep=32
ppsieve initialized: 1201 <= k <= 9999, 76 <= n <= 2000000

# more stderr.txt
shmget in attach_shmem: Invalid argument
Can't set up shared mem: -1
Will run in standalone mode.
Sieve started: 42070000000000 <= p < 42070010000000
Thread 0 starting
Error: Getting Platforms. (clGetPlatformsIDs)
called boinc_finish

EDIT: I don't know if this is important. At the the beginning of the test i use the wrong terminal and test the app on a host with a nvidia-gpu (GTX260). The app runs without problems.


Next 10 posts
[Return to PrimeGrid main page]
DNS Powered by DNSEXIT.COM
Copyright © 2005 - 2020 Rytis Slatkevičius (contact) and PrimeGrid community. Server load 0.06, 0.01, 0.00
Generated 20 Sep 2020 | 19:00:29 UTC