PrimeGrid
Please visit donation page to help the project cover running costs for this month

Toggle Menu

Join PrimeGrid

Returning Participants

Community

Leader Boards

Results

Other

drummers-lowrise
11) Message boards : Generalized Fermat Prime Search : Errors.... (Message 49510)
Posted 3036 days ago by Profile Mr. Hankey



Strange, I read about a similar error in llrcuda thread at mersenneforum some weeks ago: http://www.mersenneforum.org/showthread.php?t=14608&page=5
But it looks like an old error.

Maybe it depends on the old llrcuda build, which is handled out with prpnet. I try to remember it's version 0.60. There is newer source available, but I don't know if anyone compliled the new source as windows executable.

Regards Odi


Yes it is version .60, I also had to install an old version of the cuda dev kit to get the older lib files. the .40.17 files didn't work it needed the .32.16 versions
12) Message boards : Generalized Fermat Prime Search : Errors.... (Message 49504)
Posted 3037 days ago by Profile Mr. Hankey
Yep, genefer does run on the gtx260 that host is here:

http://www.primegrid.com/show_host_detail.php?hostid=162940

13) Message boards : Generalized Fermat Prime Search : Errors.... (Message 49502)
Posted 3037 days ago by Profile Mr. Hankey
Hmm, frustrating indeed.

Well I was thinking about pulling the GPUs and the power supply and putting them over in a different box to see if that made a difference. I guess I will try a driver sweep and clean install of the latest drivers first if that doesn't work then I will go for the hardware move.

Do you think that 2 570s and an i7 860 at max load will work on a 700w power supply? Right now there is a gtx260 and an ati 5850 in the i7 box just fine. If that will work I won't have to move the power supplies I can just swap the graphics cards.
14) Message boards : Generalized Fermat Prime Search : Errors.... (Message 49499)
Posted 3037 days ago by Profile Mr. Hankey
Ok, some new? observations.

I got prpnet installed and working to try and test llrCUDA.

I don't know if this would also apply to genefer or is specific to prpnet and not boinc but what I noticed was.

1. when I left the gpuaffinity setting to the default -1 and launched two clients one of my two GPUs (gpu 1) never seemed to get any activity. When I specified either 0 or 1 in the affinity settings I could drive the llrCUDA to either GPU. Without using the affinity settings I couldn't get the WUs to run. Does the app correctly try and select GPUs?

2. At startup there was always what appeared to be zero GPU load but max CPU load for a period of time. During this time I would see messages on the console like this:

Iter: 304380/4526670, ERROR: ROUND OFF (0.4999994338) > 0.4 Continuing from last save file. Resuming Proth prime test of 121*2^4526664+1 at bit 304258 [6.72%] Using complex irrational base DWT, FFT length = 524288, a = 3


it would do that for a while and then the WU would begin crunching on the GPU @ 97%-99% load. with a regular updating status line. like this :

121*2^4526664+1, bit: 1040000 / 4526670 [22.97%]. Time per bit: 1.371 ms.


3. GPU 0 seems to be crunching now, GPU 1 seems to hit this error :

[2012-02-12 20:02:39 PST] 121: GetNextIncompleteWorkUnit found 121*2^4526664+1 Resuming Proth prime test of 121*2^4526664+1 at bit 304258 [6.72%] Using complex irrational base DWT, FFT length = 524288, a = 3 c:/Users/XCyber/Desktop/PrimeTest/llrcuda_win64/gwpnumi.cu(1832) : cudaSafeCall( ) Runtime API error : unknown error. [2012-02-12 20:04:41 PST] 121: Could not open file [lresults.txt] for reading. Assuming user stopped with ^C [2012-02-12 20:04:41 PST] 121: ProcessWorkUnit did not complete 121*2^4526664+1 [2012-02-12 20:04:41 PST] 121: AddWorkUnitToList for 121*2^4526664+1 [2012-02-12 20:04:41 PST] 121: IsWorkUnitCompleted for 121*2^4526664+1. Returni ng false (not completed, main) [2012-02-12 20:04:41 PST] Total Time: 0:02:02 Total Work Units: 0 Special Res ults Found: 0 [2012-02-12 20:04:41 PST] PPSEhigh: Returning work. currentworkunits=0, complet edworkunits=0, quitOption=2 [2012-02-12 20:04:41 PST] 121: Returning work. currentworkunits=1, completedwor kunits=0, quitOption=2 [2012-02-12 20:04:41 PST] 27: Returning work. currentworkunits=0, completedwork units=0, quitOption=2 [2012-02-12 20:04:41 PST] Client shutdown complete [2012-02-12 20:04:41 PST] 121: AddWorkUnitToList for 121*2^4526664+1 [2012-02-12 20:04:41 PST] 121: IsWorkUnitCompleted for 121*2^4526664+1. Returni ng false (not completed, main) [2012-02-12 20:04:41 PST] 121: DeleteWorkUnit for 121*2^4526664+1


Is there some further debugging info somewhere?
15) Message boards : Generalized Fermat Prime Search : Errors.... (Message 49498)
Posted 3037 days ago by Profile Mr. Hankey
I was able to fix errors on one of my computers by setting the power saving mode from "adaptive" to performance in the nvidia 3d settings in the nvidia contol panel. Not sure this will fix your issue but something to try.


Yes, I have that already set, but it never hurts to double check.
16) Message boards : Generalized Fermat Prime Search : Errors.... (Message 49428)
Posted 3038 days ago by Profile Mr. Hankey
where else to get the window 64bit llr cuda app, the link http://pgllr.mine.nu/software/LLR/ from the llrCUDA testing thread only results in connection timed out.


LLRCuda itself is located at the latest PRPnet Package: http://uwin.mine.nu/PRPNet/

The libraries (different from genefercuda) can downloaded here http://www.bc-team.org/downloads.php?view=detail&df_id=39

Regards Odi


It looks like only the cpu version off llr is in the latest prpnet package? Or because I dled the
prpclient-5.0.5-windows-gpu.7z that is all gpu stuff only in there?

Thanks for the libraries link, I have those now.
17) Message boards : Generalized Fermat Prime Search : Errors.... (Message 49426)
Posted 3038 days ago by Profile Mr. Hankey
Yes, all of the sieve WUs run like a champ


Looking at this computer, I don't see any valid results at all except for one Genefer. You've run sieves on it in the past? Perhaps something has changed since then. It would be helpful if you ran a few sieve CUDA WUs on there to help diagnose the problem.


Ok, its got a batch of sieves running through it now.
18) Message boards : Generalized Fermat Prime Search : Errors.... (Message 49420)
Posted 3038 days ago by Profile Mr. Hankey
Where can I get the PPS_LLR cuda app for testing as you suggested?

llrCUDA testing is good place to start.

Also you can read the thread llrCUDA at mersenneforum? for recent news and developement.


where else to get the window 64bit llr cuda app, the link http://pgllr.mine.nu/software/LLR/
from the llrCUDA testing thread only results in connection timed out.
19) Message boards : Generalized Fermat Prime Search : Errors.... (Message 49418)
Posted 3038 days ago by Profile Mr. Hankey
ok, lowering the memory clocks didn't make a difference, and I tried running one card at a time by ignoring one card or the other in the cc_config file. Didn't make a difference either. Not sure what the conditions are that have allowed a few tasks to complete.

Where can I get the PPS_LLR cuda app for testing as you suggested?


I'm running out of ideas. Running LLR CUDA is the only other test I can think of, and that's merely to determine whether a similar program also fails.

Other CUDA WUs do work, right? You can run PPS Sieve and CW Sieve on those GPUs?

One other thing that you can try is to un-install and re-install the video driver. This doesn't sound like a driver problem, however.


Yes, all of the sieve WUs run like a champ
20) Message boards : Generalized Fermat Prime Search : Errors.... (Message 49383)
Posted 3038 days ago by Profile Mr. Hankey
ok, lowering the memory clocks didn't make a difference, and I tried running one card at a time by ignoring one card or the other in the cc_config file. Didn't make a difference either. Not sure what the conditions are that have allowed a few tasks to complete.

Where can I get the PPS_LLR cuda app for testing as you suggested?


Next 10 posts
[Return to PrimeGrid main page]
DNS Powered by DNSEXIT.COM
Copyright © 2005 - 2020 Rytis Slatkevičius (contact) and PrimeGrid community. Server load 0.06, 0.02, 0.00
Generated 7 Jun 2020 | 6:10:20 UTC