PrimeGrid
Please visit donation page to help the project cover running costs for this month

Toggle Menu

Join PrimeGrid

Returning Participants

Community

Leader Boards

Results

Other

drummers-lowrise

Advanced search

Message boards : Proth Prime Search : PPS sieve - output file for task absent!?

Author Message
Profile Sheng
Send message
Joined: 30 Jul 13
Posts: 14
ID: 245725
Credit: 1,830,439
RAC: 0
321 LLR Bronze: Earned 10,000 credits (26,543)Cullen LLR Bronze: Earned 10,000 credits (13,900)PPS LLR Bronze: Earned 10,000 credits (13,042)PSP LLR Bronze: Earned 10,000 credits (29,800)SoB LLR Bronze: Earned 10,000 credits (87,837)SGS LLR Bronze: Earned 10,000 credits (15,606)TRP LLR Bronze: Earned 10,000 credits (54,989)Woodall LLR Bronze: Earned 10,000 credits (39,271)PPS Sieve Amethyst: Earned 1,000,000 credits (1,341,658)TRP Sieve (suspended) Silver: Earned 100,000 credits (198,955)
Message 68258 - Posted: 11 Aug 2013 | 23:09:12 UTC

Hi there,

I encountered this problem in my desktop while trying to do pps-sieve-cuda.
every time the tasks were loaded but soon terminated with throwing the error:

pps_"file_random_name" for task ... absent.


I also searched and forum and set the "write to disk 360 seconds" --- which is by default 60 seconds.
However, it did not help at all.

So, can anyone tell me how to solve this problem?
thanks.

Profile Sheng
Send message
Joined: 30 Jul 13
Posts: 14
ID: 245725
Credit: 1,830,439
RAC: 0
321 LLR Bronze: Earned 10,000 credits (26,543)Cullen LLR Bronze: Earned 10,000 credits (13,900)PPS LLR Bronze: Earned 10,000 credits (13,042)PSP LLR Bronze: Earned 10,000 credits (29,800)SoB LLR Bronze: Earned 10,000 credits (87,837)SGS LLR Bronze: Earned 10,000 credits (15,606)TRP LLR Bronze: Earned 10,000 credits (54,989)Woodall LLR Bronze: Earned 10,000 credits (39,271)PPS Sieve Amethyst: Earned 1,000,000 credits (1,341,658)TRP Sieve (suspended) Silver: Earned 100,000 credits (198,955)
Message 68259 - Posted: 11 Aug 2013 | 23:28:56 UTC

Update:

i found that I can NOT run cuda jobs in my desktop.
So i highly suspect that pps-sieve-cuda jobs and genefer jobs were stopped due to some unknown problem with my tesla.

My X-server (display) is connected to gtx295, tesla has NO display.

Does it explain my problem?
Then how to solve it? (the centos can NOT boot if I connect display to my tesla.)

Thanks.

Profile Sheng
Send message
Joined: 30 Jul 13
Posts: 14
ID: 245725
Credit: 1,830,439
RAC: 0
321 LLR Bronze: Earned 10,000 credits (26,543)Cullen LLR Bronze: Earned 10,000 credits (13,900)PPS LLR Bronze: Earned 10,000 credits (13,042)PSP LLR Bronze: Earned 10,000 credits (29,800)SoB LLR Bronze: Earned 10,000 credits (87,837)SGS LLR Bronze: Earned 10,000 credits (15,606)TRP LLR Bronze: Earned 10,000 credits (54,989)Woodall LLR Bronze: Earned 10,000 credits (39,271)PPS Sieve Amethyst: Earned 1,000,000 credits (1,341,658)TRP Sieve (suspended) Silver: Earned 100,000 credits (198,955)
Message 68261 - Posted: 12 Aug 2013 | 0:10:22 UTC - in response to Message 68259.

Update:

i found that I can NOT run cuda jobs in my desktop.
So i highly suspect that pps-sieve-cuda jobs and genefer jobs were stopped due to some unknown problem with my tesla.

My X-server (display) is connected to gtx295, tesla has NO display.

Does it explain my problem?
Then how to solve it? (the centos can NOT boot if I connect display to my tesla.)

Thanks.



Update:

I think I solved this issue:
ppsieve-cuda$./run_pps_cuda_local.sh ppsieve version 0.3.10d (testing) Compiled Aug 12 2013 with GCC 4.4.7 20120313 (Red Hat 4.4.7-3) Intel processor found. using standard algorithm. nstart=1999980, nstep=32 ppsieve initialized: 1201 <= k <= 9999, 76 <= n <= 2000000 Sieve started: 42070000000000 <= p < 42070030000000 Thread 0 starting 42070000070587 | 9475*2^197534+1 42070000198537 | 3373*2^1046686+1 42070003101727 | 4207*2^1054290+1 42070003511309 | 6057*2^1043547+1 42070006307657 | 1513*2^1771812+1 42070006388603 | 2059*2^1816098+1 42070007177519 | 5437*2^1121592+1 42070007396759 | 7339*2^1803518+1 42070008823897 | 4639*2^952018+1 42070008858187 | 2893*2^317690+1 42070010190569 | 5625*2^1903125+1 42070011430123 | 3821*2^1406279+1 42070012301263 | 1957*2^1185814+1 42070013521999 | 1965*2^404493+1 p=42070013893633, 231.6K p/sec, 1.00 CPU cores, 46.3% done. ETA 12 Aug 01:09 42070013970587 | 7143*2^1462422+1 42070013989247 | 5037*2^838603+1 42070017332953 | 6237*2^1916994+1 42070018235321 | 1941*2^363948+1 42070019542387 | 8587*2^1703626+1 42070023987581 | 9811*2^318944+1 42070024339237 | 9257*2^1170495+1 42070024532551 | 4311*2^1690093+1 42070024936837 | 5679*2^1726142+1 42070024995961 | 9111*2^1707153+1 42070026021997 | 4039*2^1819590+1 42070027452199 | 1323*2^854008+1 p=42070028311553, 240.3K p/sec, 1.00 CPU cores, 94.4% done. ETA 12 Aug 01:09 42070029006583 | 5943*2^663870+1 Thread 0 completed Waiting for threads to exit Sieve complete: 42070000000000 <= p < 42070030000000 Found 27 factors count=955289,sum=0x2dbc17167afb6a8d Elapsed time: 126.96 sec. (0.02 init + 126.94 sieve) at 237483 p/sec. Processor time: 126.68 sec. (0.02 init + 126.66 sieve) at 238010 p/sec. Average processor utilization: 1.01 (init), 1.00 (sieve)


after re-compile the bin-files locally.

but compilation for BONIC seems generates error/warning msgs.....

Profile Sheng
Send message
Joined: 30 Jul 13
Posts: 14
ID: 245725
Credit: 1,830,439
RAC: 0
321 LLR Bronze: Earned 10,000 credits (26,543)Cullen LLR Bronze: Earned 10,000 credits (13,900)PPS LLR Bronze: Earned 10,000 credits (13,042)PSP LLR Bronze: Earned 10,000 credits (29,800)SoB LLR Bronze: Earned 10,000 credits (87,837)SGS LLR Bronze: Earned 10,000 credits (15,606)TRP LLR Bronze: Earned 10,000 credits (54,989)Woodall LLR Bronze: Earned 10,000 credits (39,271)PPS Sieve Amethyst: Earned 1,000,000 credits (1,341,658)TRP Sieve (suspended) Silver: Earned 100,000 credits (198,955)
Message 68262 - Posted: 12 Aug 2013 | 0:38:30 UTC
Last modified: 12 Aug 2013 | 0:39:51 UTC

Hi all:

I think the issue is solved and gone since I updated glibc-devel.i686 for my CentOS 6.x.
Now the cuda jobs (currently for pps-sieve-cuda) in Boinc is working after rebooting the OS.

This thread is closed.

Thanks.

Message boards : Proth Prime Search : PPS sieve - output file for task absent!?

[Return to PrimeGrid main page]
DNS Powered by DNSEXIT.COM
Copyright © 2005 - 2020 Rytis Slatkevičius (contact) and PrimeGrid community. Server load 0.00, 0.01, 0.00
Generated 31 Oct 2020 | 23:39:30 UTC